Personal budget software for the rest of us



This page contains links to download the current Stable version of Buddi. Buddi is available for a number of operating systems. Click on the name of your operating system below to download the correct version of Buddi:

Please note that Buddi requires Java 1.6 or higher. If you are running Java 1.5, and cannot upgrade for some reason, please use Buddi version or earlier.

There are also some alternate program icons for users who do not use the dollar sign. If your currency is not here, feel free to make a 512x512 png with it and send it to me! (The base .xcf file is in the git repository, you can email me if you cannot find it).